How to install Rails 3.2.3?


This release changes the default value of config.active_record.whitelist_attributes to true. This change only affects newly generated applications so it should not cause any backwards compatibility issues for users who are upgrading but it may affect some tutorials and introductory material. Rails 3.2.3 also introduces a new option that allows you to control the behavior of remote forms when it comes to authenticity_token generation. If you want to fragment cache your forms, authenticity token will also get cached, which isn’t acceptable. However, if you only use such forms with ajax, you can disable token generation, because it will be fetched from meta tag. Starting with 3.2.3, you have an option to stop generating authenticity_token in remote forms (ie. :remote => true is passed as an option), by setting config.action_view.embed_authenticity_token_in_remote_forms = false. Please note that this will break sending those forms with javascript disabled. If you choose to not generate the token in remote forms by default, you can still explicitly pass :authenticity_token => true when generating the form to bypass this setting. The option defaults to true, which means that existing apps are NOT affected.

1. Install rails 3.2.3 gem

gem install rails -v=3.2.3

2. To evaluate Javascript from with in Ruby you need to install

gem install therubyracer

3. Install mysql2 library for ruby to establish connection to database and query on connection

gem install mysql2 -v=0.3

4. To execute rake task install the gem

gem install rake -v=0.9.2

5. bcrypt-ruby is a sophisticated and secure hash algorithm designed by the OpenBSD project for hashing passwords

gem install bcrypt-ruby -v=3.0.0

6. ExecJS lets JavaScript code to run from Ruby. It automatically picks the best runtime available to evaluate your JavaScript program, then returns the result to you as a Ruby object.

gem install execjs

7. The jquery-rails gem which comes with Rails as the standard JavaScript library gem. This gem contains an engine class which inherits from Rails::Engine. By doing this, Rails is informed that the directory for this gem may contain assets and the app/assets, lib/assets and vendor/assets directories.

gem install jquery-rails

8. Asset pipeline

The asset pipeline provides framework to compress Javascript and Css assets. It also adds the ability to write these assets in other languages such as Coffeescript, Sass and ERB.

In previous version of Rails, all assets were located in subdirectories of public such as images, javascripts and stylesheets. With the asset pipeline, the prefferred location for these assets is now the app/assets directory.

For example, if ProjectsController is generated, Rails will add a new file at

app/assets/javascripts/projects.js.coffee

app/assets/stylesheets/projects.css.scss.

Rails 3.2.3 Gemfile

gem “rails”, “~> 3.2.3″

# Bundle edge Rails instead:

# gem ‘rails’, :git => ‘git://github.com/rails/rails.git’

gem ‘mysql2′, ‘>= 0.3′

gem ‘rake’, ‘=0.9.2′

gem ‘jquery-rails’

gem ‘bcrypt-ruby’, ‘~> 3.0.0′

gem ‘execjs’

gem ‘therubyracer’, :platforms => :ruby

# Gems used only for assets and not required

# in production environments by default.

group :assets do

gem ‘sass-rails’, ‘~> 3.2.3′

gem ‘coffee-rails’, ‘~> 3.2.1′

gem ‘uglifier’, ‘>= 1.0.3′

end

# Use unicorn as the web server

# gem ‘unicorn’

# Deploy with Capistrano

# gem ‘capistrano’

# To use debugger

# gem ‘ruby-debug19′, :require => ‘ruby-debug’

group :test do

# Pretty printed test output

gem ‘turn’, :require => false

end

Source:Railscarma.com

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s